Closed Thread
Results 1 to 2 of 2

Reload Thread: need some help!

  1. #1
    lowriderram_95's Avatar
    lowriderram_95 is offline VW Surgeon



    Join Date
    Jun 2007
    Location
    Little Rock, AR
    Age
    26
    Posts
    1,642
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    28 Post(s)

    need some help!

    ok so I finally found my blown 2 channel amps. One of them is a kx150.2 and the other is a pg tantrum 250.2. I don't have a socket small enough to take the tantrum apart so I just didn't mess with it but I found the problem on the kx amp. there is a white rectangular piece that looks burnt. it has .2 ohm on the side of it. what can that be and where can I get another one? or would it be easier to just send it in to get it fixed?



    (b):hoxie08, dacheatham, Mr.Foca, RetroAudioInc, pro-rabbit (t):dave_damage, j.clark90, tubermaguber

    RE XXX v1 10
    SQ2200.1
    AQ120.4
    SQ200.2




  2. #2
    lowriderram_95's Avatar
    lowriderram_95 is offline VW Surgeon

    Threadstarter


    Join Date
    Jun 2007
    Location
    Little Rock, AR
    Age
    26
    Posts
    1,642
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    28 Post(s)

    Re: need some help!

    bump



    (b):hoxie08, dacheatham, Mr.Foca, RetroAudioInc, pro-rabbit (t):dave_damage, j.clark90, tubermaguber

    RE XXX v1 10
    SQ2200.1
    AQ120.4
    SQ200.2

Closed Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum