Closed Thread
Results 1 to 2 of 2

Reload Thread: New amp install..problems with set up

  1. #1
    60_cent's Avatar
    60_cent is offline CarAudio.com Elite



    Join Date
    Mar 2003
    Location
    atlanta, GA
    Posts
    1,392
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Icon32 New amp install..problems with set up

    I have a Memphis Belle that was just installed today. This amp is great, probably the best amp I have ever owned.

    The only problem I have is with the sub side of the amp. It is a 5 channel amp, the problem is that I can't find a gain for the sub side. There is however a module that was installed under the dash to control the volume of the subs.

    The problem is that I have to crank that module all the way up to get subs to play loud. The sub control on the radio ( Alpine 7897 ) also turned all the way up. WTF

    The amp is rated at 1100w rms at 1ohm. I'm running two TREO SS 12.44 in a ported box at 38htz wired in paralell at 1 ohm. The subs are loud *** hell but are barely even moving much...???

    My point is that I know that the subs have more in them judging by the excursion but how the hell do I turn the gain up.







  2. #2
    60_cent's Avatar
    60_cent is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Mar 2003
    Location
    atlanta, GA
    Posts
    1,392
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: New amp install..problems with set up

    Finally got everything tweaked out. There are alot of adjustments to make, in the past all you had to do was adjust the bass and treble, that's it.

    Over all I'm pleased with the system, it loud as hell and sound clean and clear.. . THe only thing I wish was a little better is the low bass. My old system with two HX2 15's in a sealed box hit lower but not as hard.




Closed Thread

Similar Threads

  1. im new. how to install 4-CH amp?
    By Forty-Ouncer in forum Wiring, Electrical and Installation Help
    Replies: 10
    Last Post: 06-28-2004, 09:35 AM
  2. amp for a set of speakers (?)
    By Chamoru in forum Speakers
    Replies: 3
    Last Post: 10-23-2003, 03:09 AM
  3. amp for a set of speakers (?)
    By Chamoru in forum Speakers
    Replies: 3
    Last Post: 10-05-2003, 06:06 PM
  4. How do i install this stuff?
    By ridered36 in forum Wiring, Electrical and Installation Help
    Replies: 4
    Last Post: 09-16-2003, 12:43 PM
  5. How to set amp gain at 2V?
    By Bobyota in forum Amplifiers
    Replies: 4
    Last Post: 09-13-2003, 07:36 PM

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum