Closed Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 23

Reload Thread: Alpine MRP-M1000 mono, is it good enough????

  1. #1
    julz's Avatar
    julz is offline julz



    Join Date
    Jun 2008
    Location
    South Africa
    Posts
    11
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Alpine MRP-M1000 mono, is it good enough????

    Hi guys

    Im new to this so sorry for been a noob. Listen, i just got some cool car sound. Everything is Alpine, including the head unit. I honestly think that my Amp is not strong enough for what i have installed. I f someone could shed some light onto my problem, i would greatly appreciate it. What i have installed is:

    1 x MRP-1000 mono
    1 x CDA-9886 head unit
    2 x SPR-13C 5-1/4 Coaxil in the doors
    2 x SWR-1022D 10"

    I know my Amp is not sufficient for all this. Advice anyone. Oh yes, everything is type R stuff.

    Julz out







  2. #2
    Macklessdaddy's Avatar
    Macklessdaddy is offline CarAudio.com Elite



    Join Date
    Jun 2006
    Location
    San Diego
    Posts
    1,762
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Alpine MRP-M1000 mono, is it good enough????

    Quote Originally Posted by julz View Post
    Hi guys

    Im new to this so sorry for been a noob. Listen, i just got some cool car sound. Everything is Alpine, including the head unit. I honestly think that my Amp is not strong enough for what i have installed. I f someone could shed some light onto my problem, i would greatly appreciate it. What i have installed is:

    1 x MRP-1000 mono
    1 x CDA-9886 head unit
    2 x SPR-13C 5-1/4 Coaxil in the doors
    2 x SWR-1022D 10"

    I know my Amp is not sufficient for all this. Advice anyone. Oh yes, everything is type R stuff.

    Julz out
    your amp is good enough,but what is powering your speakers



    Kenwood x991
    Alpine Spx-17Ref
    Cadence Zrs 9004
    Oz Me 10" Sealed
    Cadence Zrs 6000D

    My Ebay http://feedback.ebay.com/ws/eBayISAP...ab=AllFeedback

    Refs Louisiana _Crx-Killa Camry-Traksta15-Ganesh134-sacking74



    Quote Originally Posted by jon_k View Post
    Turn the gain down? Quit running impedance at unstable?

  3. #3
    julz's Avatar
    julz is offline julz

    Threadstarter


    Join Date
    Jun 2008
    Location
    South Africa
    Posts
    11
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Alpine MRP-M1000 mono, is it good enough????

    Dude, that is powering everything. The guy that installed all this said that it will be ok. Perhaps i got taken for a ride. What amp should i get to power the speakers?

    Julz




  4. #4
    ashtrey1212's Avatar
    ashtrey1212 is offline Gimmie Some Sugar Baby!!!



    Join Date
    Mar 2008
    Location
    Amherstburg, ON
    Age
    29
    Posts
    383
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Alpine MRP-M1000 mono, is it good enough????

    Quote Originally Posted by julz View Post
    Dude, that is powering everything. The guy that installed all this said that it will be ok. Perhaps i got taken for a ride. What amp should i get to power the speakers?

    Julz
    I think those speakers are 80 watts rms if my memory is correct. If you just get yourself a decent two channel amp for the front you'll be fine. Or you could get a really sweet four channel and put some speakers in the back.





    Head Unit: Alpine IVA-W505 w/ PXA-H100
    Front: Hertz HSK 130's
    Rear: Hertz HCK 690's
    4 Channel: Alpine PDX4.150
    Subs: 2 12" Alpine Type X's
    Mono Amps: 2 Alpine PDX1.1000's
    Electrical: 160 amp alternator, Big 3,
    Front Battery: NGT Yellow Top
    Rear Battery: NGT Yellow Top
    (Second rear battery coming soon)

  5. #5
    tv559's Avatar
    tv559 is offline The Don



    Join Date
    Oct 2007
    Location
    Fresno, Ca
    Posts
    1,560
    Post Thanks / Like
    Mentioned
    1 Post(s)

    Re: Alpine MRP-M1000 mono, is it good enough????

    Quote Originally Posted by julz View Post
    Dude, that is powering everything. The guy that installed all this said that it will be ok. Perhaps i got taken for a ride. What amp should i get to power the speakers?

    Julz


    WOW That guy lied!!



    Refs. Sold to: Superduper,ncpalafox,lmsfootball35,Schicksal,Nuked sodapop,G0NGSHOW,TacoSauce,scooter924,eclipsepb25, RetroAudioinc,smd4life,Stateprop486,Got_Bass89, Anniku989,Ryan1126,altoncustomtech-- Traded with: SteveyHustle--Bought from: MOJOBASS, Xtremebass5,Path2spl,Violentaudio,5.3bowtie, mike75356,matrxx dude, Kovemaster559,acex3a,Sundownz,Grinder1989, revrider1,andrew2944r,hornedfrog1985,tez4life .

    Quote Originally Posted by 350zspl View Post
    i got the large on front
    the small in rear

    they work for me

  6. #6
    mavster's Avatar
    mavster is offline CarAudio.com Elite



    Join Date
    Jul 2007
    Location
    New York, NY
    Age
    27
    Posts
    1,031
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Alpine MRP-M1000 mono, is it good enough????

    He is running the Coax's off the headunit...and using the mono amp to power the subs..



    Ride: 2001 Nissan Altima GXE
    HeadUnit: Alpine CDA-9887
    Front Components: Blaupunkt VC660s
    Front Components Amplifier: Blaupunkt THA2125
    Subwoofer: JBL GTO1204BP-D
    Subwoofer Amplifier: Blaupunkt THA475

    refs: Nismos14, Zeuslicious, perfecxionX, almond, brchd, RoLLaxPhile, Ultimate157, kmanian, slammed, 528hz, abdulwq, LopezEL, brazilianguy, kovemaster559, Earthman, jrgreene1968, ampjunkielikeme.

  7. #7
    julz's Avatar
    julz is offline julz

    Threadstarter


    Join Date
    Jun 2008
    Location
    South Africa
    Posts
    11
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Alpine MRP-M1000 mono, is it good enough????

    Ok, well that explains the crappy sound! I think ill take it to someone else before my car blows up. I think ill get a 4chnl. Should i go alpine?




  8. #8
    ashtrey1212's Avatar
    ashtrey1212 is offline Gimmie Some Sugar Baby!!!



    Join Date
    Mar 2008
    Location
    Amherstburg, ON
    Age
    29
    Posts
    383
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Alpine MRP-M1000 mono, is it good enough????

    If you go alpine, get a PDX series 4 channel. Don't do what I did and buy crap product the first time around and then kick yourself in the *** for a full year until you finally buy something good. Just be a man about your buisness and get something great the first time.





    Head Unit: Alpine IVA-W505 w/ PXA-H100
    Front: Hertz HSK 130's
    Rear: Hertz HCK 690's
    4 Channel: Alpine PDX4.150
    Subs: 2 12" Alpine Type X's
    Mono Amps: 2 Alpine PDX1.1000's
    Electrical: 160 amp alternator, Big 3,
    Front Battery: NGT Yellow Top
    Rear Battery: NGT Yellow Top
    (Second rear battery coming soon)

  9. #9
    ashtrey1212's Avatar
    ashtrey1212 is offline Gimmie Some Sugar Baby!!!



    Join Date
    Mar 2008
    Location
    Amherstburg, ON
    Age
    29
    Posts
    383
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Alpine MRP-M1000 mono, is it good enough????

    Oh ya, and ditch the coax's and get a component system and 6x9's. I don't care if they don't fit in your car, just make them fit.





    Head Unit: Alpine IVA-W505 w/ PXA-H100
    Front: Hertz HSK 130's
    Rear: Hertz HCK 690's
    4 Channel: Alpine PDX4.150
    Subs: 2 12" Alpine Type X's
    Mono Amps: 2 Alpine PDX1.1000's
    Electrical: 160 amp alternator, Big 3,
    Front Battery: NGT Yellow Top
    Rear Battery: NGT Yellow Top
    (Second rear battery coming soon)

  10. #10
    julz's Avatar
    julz is offline julz

    Threadstarter


    Join Date
    Jun 2008
    Location
    South Africa
    Posts
    11
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Alpine MRP-M1000 mono, is it good enough????

    Ill def get a good amp. Dude, are those Coax's crap? They were expensive. If i had to get a good amp to run my speakers, would they sound good?




  11. #11
    cleansoundzz's Avatar
    cleansoundzz is offline CarAudio.com Elite



    Join Date
    Apr 2008
    Location
    Buena Park
    Posts
    1,837
    Post Thanks / Like
    Mentioned
    1 Post(s)

    Re: Alpine MRP-M1000 mono, is it good enough????

    Alpine amps did not do me much good but I hear good things about the PDX's



    02 4-Runner-Alpe CDE-HD148BT-Acntrl 3.2, Epictr, Alpe PDR F50 on Crssfre Sprates-Alpe PDR M12 on RF T1 15 @ 34hz
    90 300zx-Alpe CDE-147BT-Acntrl 3.1, Epictr, Alpe PDR F50 on Crssfre Separates-Alpe PDR M65 on NVX XQW104 @35hz

    REFERENCES: BEATNOUTDAFRAME, VIVEET, CX-7HEAVEN, GMAN42, SUNDOWNZ, ZERMELO, M3NTAL, GAM3OVR, HEMI=22s, PROJECTPECKIN, KRISFNBZ, WHEELIEKING71, MR. RONIN-2U, ROBERTQ, DJM4RSHM21LOW, BLACKBONNIE, GYMFREAK101, STUCKINOK, SIACARMAN, ONEINTHESAC, 97SRAD750, ETC AND MANY MANY MORE[/FONT]
    Formerly cleansoundz

  12. #12
    ashtrey1212's Avatar
    ashtrey1212 is offline Gimmie Some Sugar Baby!!!



    Join Date
    Mar 2008
    Location
    Amherstburg, ON
    Age
    29
    Posts
    383
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Alpine MRP-M1000 mono, is it good enough????

    Quote Originally Posted by julz View Post
    Ill def get a good amp. Dude, are those Coax's crap? They were expensive. If i had to get a good amp to run my speakers, would they sound good?
    Oh I'm not saying the coax's are crap, I'm just saying that an Alpine Type R comp set would sound way better than Type R coax's.





    Head Unit: Alpine IVA-W505 w/ PXA-H100
    Front: Hertz HSK 130's
    Rear: Hertz HCK 690's
    4 Channel: Alpine PDX4.150
    Subs: 2 12" Alpine Type X's
    Mono Amps: 2 Alpine PDX1.1000's
    Electrical: 160 amp alternator, Big 3,
    Front Battery: NGT Yellow Top
    Rear Battery: NGT Yellow Top
    (Second rear battery coming soon)

  13. #13
    julz's Avatar
    julz is offline julz

    Threadstarter


    Join Date
    Jun 2008
    Location
    South Africa
    Posts
    11
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Alpine MRP-M1000 mono, is it good enough????

    Everything is brand new, i have never used the stuff, so ill get them to swop all the components that i dont want for better stuff. Then ill get it installed by a professional. Are my speakers running off the head unit?




  14. #14
    ashtrey1212's Avatar
    ashtrey1212 is offline Gimmie Some Sugar Baby!!!



    Join Date
    Mar 2008
    Location
    Amherstburg, ON
    Age
    29
    Posts
    383
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Alpine MRP-M1000 mono, is it good enough????

    Quote Originally Posted by julz View Post
    Ill def get a good amp. Dude, are those Coax's crap? They were expensive. If i had to get a good amp to run my speakers, would they sound good?
    But if you amp those coax's they'll probably sound good. Just don't crank any bass out of them or they'll start popping





    Head Unit: Alpine IVA-W505 w/ PXA-H100
    Front: Hertz HSK 130's
    Rear: Hertz HCK 690's
    4 Channel: Alpine PDX4.150
    Subs: 2 12" Alpine Type X's
    Mono Amps: 2 Alpine PDX1.1000's
    Electrical: 160 amp alternator, Big 3,
    Front Battery: NGT Yellow Top
    Rear Battery: NGT Yellow Top
    (Second rear battery coming soon)

  15. #15
    julz's Avatar
    julz is offline julz

    Threadstarter


    Join Date
    Jun 2008
    Location
    South Africa
    Posts
    11
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Alpine MRP-M1000 mono, is it good enough????

    Guys, i live in South Africa, so this type of sound is **** expensive. All imported etc. I just hope it all sounds good afterwards. Are those 10" any good?




Closed Thread
Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum