Closed Thread
Results 1 to 3 of 3

Reload Thread: planet audio amps

  1. #1
    joshpoints's Avatar
    joshpoints is offline CarAudio.com Veteran



    Join Date
    Jan 2003
    Location
    San Ma Tonga Central, CA
    Age
    31
    Posts
    3,165
    Post Thanks / Like
    Mentioned
    0 Post(s)

    planet audio amps

    Wow!!. Just installed a planet audio amp in my car. Sounds clean, amazing. THere is no hiss when I adjust the crossovers on the amp like my cheap amps. amazing sound. Five year warranty!!! I'm loving it. I thank you all that gave me the advice to go with planet audio amps. I got it for a decent price, sounds good, long warranty. I do have one question. It's probably a stupid question, but what is the 0 degrees to 180 degrees phase for? All my other amps were too cheap to have this feature I guess.







  2. #2
    ws140's Avatar
    ws140 is offline ~`[]D[]][\/]][[]D`~



    Join Date
    Oct 2002
    Location
    MA
    Age
    29
    Posts
    671
    Post Thanks / Like
    Mentioned
    0 Post(s)
    it is if your subs polarity is switched up. Like if you had them inverted in a box or you connected the wires wrong. It lets you switch the signal so it would not cancel out the other sub. Hard to explain, but hope that helps.



    Alpine CDA-9813
    Infinity Kappa 60.5s Component Speakers
    U.S. Acoutics 2080x for the comps (80x2 @ 4 ohms)
    1 ed e12O.44 in a 2ft.^3 sealed box.
    Soundstream RUB500-1 for the sub (400x1 @ 2 ohms)

  3. #3
    joshpoints's Avatar
    joshpoints is offline CarAudio.com Veteran

    Threadstarter


    Join Date
    Jan 2003
    Location
    San Ma Tonga Central, CA
    Age
    31
    Posts
    3,165
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Originally posted by ws140
    it is if your subs polarity is switched up. Like if you had them inverted in a box or you connected the wires wrong. It lets you switch the signal so it would not cancel out the other sub. Hard to explain, but hope that helps.
    So you're saying if I would have wired my speaker wrong like i sent the + wire to the neg. terminal of the sub and the neg wire to the + terminal?




Closed Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum