User Tag List

Closed Thread
Page 14 of 18 FirstFirst 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 LastLast
Results 196 to 210 of 259

Reload Thread: How long have you been using your amplifier make\model\time

  1. #196
    cleansoundzz's Avatar
    cleansoundzz is offline CarAudio.com Elite



    Join Date
    Apr 2008
    Location
    Buena Park
    Posts
    1,840
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: How long have you been using your amplifier make\model\time

    So far all of my 2007 RF Power Series amps for over a year,



    02 4-Runner-Alpe CDE-HD148BT-Acntrl 3.2-RF P400x4 on Crssfre Sprates-Alpe RF T1500-1bdCP on RF T2 12@34hz
    90 300zx-Alpe CDE-147BT-Acntrl 3.1-Alpe F-50 on Crssfre Separates-Alpe F-65 on NVX XQW104 @35hz

    REFERENCES: BEATNOUTDAFRAME, VIVEET, CX-7HEAVEN, GMAN42, SUNDOWNZ, ZERMELO, M3NTAL, GAM3OVR, HEMI=22s, PROJECTPECKIN, KRISFNBZ, WHEELIEKING71, MR. RONIN-2U, ROBERTQ, DJM4RSHM21LOW, BLACKBONNIE, GYMFREAK101, STUCKINOK, SIACARMAN, ONEINTHESAC, 97SRAD750, ETC AND MANY MANY MORE[/FONT]
    Formerly cleansoundz




  2. #197
    Join Date
    Jan 2005
    Location
    Farmington, NM
    Age
    93
    Posts
    2,463
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: How long have you been using your amplifier make\model\time

    I've been using my RD D5 for a year now without any issues. It's been wired as low as .25 ohms and beat on and played music with and its still tanking along...



    --My truck: 2007 GMC 1500 crew cab, Kenwood DNX570HD, DLS front stage, SQ3500.1, 3x RD Alpha Max 15"s in 6th order blow through, Second Skin deadening.

    --Wife's car: 2013 Chevrolet Impala LTZ, Kenwood DNX470, GermanMAESTRO components on CT125.2, 2x AT10"s on an AT800.1, RF Deadskin deadening.

    --Work truck: 2014 GMC 2500 crew cab, Kenwood DNX470, Kenwood front stage, DD M1A on a pair of American Bass XD10s.

  3. #198
    RMF419's Avatar
    RMF419 is offline Senior VIP Member



    Join Date
    Aug 2006
    Location
    Toledo Ohio
    Posts
    160
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: How long have you been using your amplifier make\model\time

    Fusion 4ch FP-504, year and half. Eclipse EA3422 4ch, 5 years with one year of garage duty, hooked up to an old car battery that I would recharge when needed.



    2 Soundstream RUB4.600
    Audax TW025A2 tweeter in the A-Piller.
    Peerless 830986 3" Midrange in the sails.
    Peerless 830946 SLS 6.5 Midbass in the doors.
    Tang Band W69-1042J 6"x9" Subwoofers.
    Lanzar Optidrive 10-Channel crossover.
    Counterfit Pionner Double Din
    2ga welding cable and 12ga speaker wire.

  4. #199
    Brian Owens's Avatar
    Brian Owens is offline CarAudio.com Elite



    Join Date
    May 2003
    Location
    Denton, Tx
    Age
    44
    Posts
    1,287
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: How long have you been using your amplifier make\model\time

    I just hooked up an Alphasonic 2150 in a guys car this morning that I have had since the late 80's. Still works like a champ!



    2000 Suburban - (4) BTL 15's and (4) IA 40.1's = 157.7 dB at 37 Hz.
    1992 Astro Van - (6) BTL 15's and (6) IA 40.1's = 159.7 dB at 43 Hz.

    no system right now. . .
    Next system: (2) Massive Nx4 amps, (1) Massive N4 amp, (1) Audiocontrol EQL and 2XS
    (12) AA Carbon Fiber 7" mids, (8) Morel MDT-12 tweeters, (1) 15" UFO BTL

    REFS: iceteebone,jntar,djman37,TeamPSI,James Bang,96MaxGLE,photocrazy8,xclusiv3,DBDesignsElite, Amalan

  5. #200
    cleansoundzz's Avatar
    cleansoundzz is offline CarAudio.com Elite



    Join Date
    Apr 2008
    Location
    Buena Park
    Posts
    1,840
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: How long have you been using your amplifier make\model\time

    I couldn't last any more. Tired out of the RF amps with the equalization issues. Been using a Digital Designs M2A and C4B for about a month and a half.



    02 4-Runner-Alpe CDE-HD148BT-Acntrl 3.2-RF P400x4 on Crssfre Sprates-Alpe RF T1500-1bdCP on RF T2 12@34hz
    90 300zx-Alpe CDE-147BT-Acntrl 3.1-Alpe F-50 on Crssfre Separates-Alpe F-65 on NVX XQW104 @35hz

    REFERENCES: BEATNOUTDAFRAME, VIVEET, CX-7HEAVEN, GMAN42, SUNDOWNZ, ZERMELO, M3NTAL, GAM3OVR, HEMI=22s, PROJECTPECKIN, KRISFNBZ, WHEELIEKING71, MR. RONIN-2U, ROBERTQ, DJM4RSHM21LOW, BLACKBONNIE, GYMFREAK101, STUCKINOK, SIACARMAN, ONEINTHESAC, 97SRAD750, ETC AND MANY MANY MORE[/FONT]
    Formerly cleansoundz

  6. #201
    cleansoundzz's Avatar
    cleansoundzz is offline CarAudio.com Elite



    Join Date
    Apr 2008
    Location
    Buena Park
    Posts
    1,840
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: How long have you been using your amplifier make\model\time

    Back to RF Power Series since 10/10.



    02 4-Runner-Alpe CDE-HD148BT-Acntrl 3.2-RF P400x4 on Crssfre Sprates-Alpe RF T1500-1bdCP on RF T2 12@34hz
    90 300zx-Alpe CDE-147BT-Acntrl 3.1-Alpe F-50 on Crssfre Separates-Alpe F-65 on NVX XQW104 @35hz

    REFERENCES: BEATNOUTDAFRAME, VIVEET, CX-7HEAVEN, GMAN42, SUNDOWNZ, ZERMELO, M3NTAL, GAM3OVR, HEMI=22s, PROJECTPECKIN, KRISFNBZ, WHEELIEKING71, MR. RONIN-2U, ROBERTQ, DJM4RSHM21LOW, BLACKBONNIE, GYMFREAK101, STUCKINOK, SIACARMAN, ONEINTHESAC, 97SRAD750, ETC AND MANY MANY MORE[/FONT]
    Formerly cleansoundz

  7. #202
    cleansoundzz's Avatar
    cleansoundzz is offline CarAudio.com Elite



    Join Date
    Apr 2008
    Location
    Buena Park
    Posts
    1,840
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: How long have you been using your amplifier make\model\time

    Back with DD



    02 4-Runner-Alpe CDE-HD148BT-Acntrl 3.2-RF P400x4 on Crssfre Sprates-Alpe RF T1500-1bdCP on RF T2 12@34hz
    90 300zx-Alpe CDE-147BT-Acntrl 3.1-Alpe F-50 on Crssfre Separates-Alpe F-65 on NVX XQW104 @35hz

    REFERENCES: BEATNOUTDAFRAME, VIVEET, CX-7HEAVEN, GMAN42, SUNDOWNZ, ZERMELO, M3NTAL, GAM3OVR, HEMI=22s, PROJECTPECKIN, KRISFNBZ, WHEELIEKING71, MR. RONIN-2U, ROBERTQ, DJM4RSHM21LOW, BLACKBONNIE, GYMFREAK101, STUCKINOK, SIACARMAN, ONEINTHESAC, 97SRAD750, ETC AND MANY MANY MORE[/FONT]
    Formerly cleansoundz

  8. #203
    goingdef's Avatar
    goingdef is offline CarAudio.com Veteran



    Join Date
    Jan 2008
    Location
    Norfolk VA
    Age
    34
    Posts
    2,833
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: How long have you been using your amplifier make\model\time

    RF T600.2(bridged 2 hx2 12"s 2ohms final load) & RF T400.2(mb quart comp set) 2 years no issues.




  9. #204
    Bettr n' Revrse's Avatar
    Bettr n' Revrse is offline I do what I want



    Join Date
    Dec 2010
    Location
    Grand Junction, CO
    Posts
    16,860
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: How long have you been using your amplifier make\model\time

    Like a week

    ---------- Post added at 11:34 PM ---------- Previous post was at 11:33 PM ----------

    For everything then I switch




    Western Rep.

    99 Honda CRV: (Always Changing) ___________ 79 F-150: Show Truck ________________
    -Head Unit: Eclipse CD7100________________ -Head Unit: Eclipse CD7100
    -Sub Stage: Sundown SD-2 8's sealed________ -Sub Stage: Looking
    -Mids/Highs: Deciding_____________________ -Mids/Highs: Scan Speak & Blaupunkt
    -Sub Amp: MMATS Hifi 6 channel____________ -Sub Amp: American Warrior Set (Zed Built)
    -Mid Amp: ^^^ 5/6 bridged at 1 ohm_________ -Mid Amp: ^^^

  10. #205
    subzero's Avatar
    subzero is offline CarAudio.com Veteran



    Join Date
    Sep 2008
    Location
    Phoenix, AZ
    Age
    37
    Posts
    6,370
    Post Thanks / Like
    Images
    30
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: How long have you been using your amplifier make\model\time

    I used my Soundstream TRX1000D's for about 3 years no problems, then My alterntor died, voltage dropped to 9.5, killed one amp.

    I have been using the new Soundstream X3.71 amps since febuary, no problems. and they do rated.

    I have been using some OLD Soundstream XTA 360.2 and XTA360.4, no issues there either. Good amps




  11. #206
    cleansoundzz's Avatar
    cleansoundzz is offline CarAudio.com Elite



    Join Date
    Apr 2008
    Location
    Buena Park
    Posts
    1,840
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: How long have you been using your amplifier make\model\time

    Don't let this thread die!!!



    02 4-Runner-Alpe CDE-HD148BT-Acntrl 3.2-RF P400x4 on Crssfre Sprates-Alpe RF T1500-1bdCP on RF T2 12@34hz
    90 300zx-Alpe CDE-147BT-Acntrl 3.1-Alpe F-50 on Crssfre Separates-Alpe F-65 on NVX XQW104 @35hz

    REFERENCES: BEATNOUTDAFRAME, VIVEET, CX-7HEAVEN, GMAN42, SUNDOWNZ, ZERMELO, M3NTAL, GAM3OVR, HEMI=22s, PROJECTPECKIN, KRISFNBZ, WHEELIEKING71, MR. RONIN-2U, ROBERTQ, DJM4RSHM21LOW, BLACKBONNIE, GYMFREAK101, STUCKINOK, SIACARMAN, ONEINTHESAC, 97SRAD750, ETC AND MANY MANY MORE[/FONT]
    Formerly cleansoundz

  12. #207
    Buck's Avatar
    Buck is offline always low Buck is a Supporting Member of the forum!



    Join Date
    May 2008
    Location
    Nashville
    Posts
    18,378
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: How long have you been using your amplifier make\model\time

    I've had one of my eD 9.1 amps for 3 years, I think I thought I blew it once, but I actually didn't. I've had another one for 2 years, but just put it in back in march. Then I have a 9.2x that I've had for 2 years and it has been used the whole time, both on speakers and subs. None of these amps has had an easy lifetime. They are current hogs it seems, but they are tough.



    Alpine - ASE (local) - Batcap - C&D Tech - CT Sounds - DC - eD - Excessive Amperage - Rainbow

  13. #208
    cleansoundzz's Avatar
    cleansoundzz is offline CarAudio.com Elite



    Join Date
    Apr 2008
    Location
    Buena Park
    Posts
    1,840
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: How long have you been using your amplifier make\model\time

    Bump it up



    02 4-Runner-Alpe CDE-HD148BT-Acntrl 3.2-RF P400x4 on Crssfre Sprates-Alpe RF T1500-1bdCP on RF T2 12@34hz
    90 300zx-Alpe CDE-147BT-Acntrl 3.1-Alpe F-50 on Crssfre Separates-Alpe F-65 on NVX XQW104 @35hz

    REFERENCES: BEATNOUTDAFRAME, VIVEET, CX-7HEAVEN, GMAN42, SUNDOWNZ, ZERMELO, M3NTAL, GAM3OVR, HEMI=22s, PROJECTPECKIN, KRISFNBZ, WHEELIEKING71, MR. RONIN-2U, ROBERTQ, DJM4RSHM21LOW, BLACKBONNIE, GYMFREAK101, STUCKINOK, SIACARMAN, ONEINTHESAC, 97SRAD750, ETC AND MANY MANY MORE[/FONT]
    Formerly cleansoundz

  14. #209
    thevic24's Avatar
    thevic24 is offline my silence is deadly...



    Join Date
    Apr 2007
    Location
    right behind you
    Posts
    5,822
    Post Thanks / Like
    Images
    7
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: How long have you been using your amplifier make\model\time

    Hifonics BRZ 2100.1d and ZX! 200.2 since January this year. (my truck)

    MTX 6500d and Bazooka EL460, been in the wife's new car for about 4 months but were in the last car for 5 years....still going.



    Silently stalking you through glass....

  15. #210
    dontbeaprix's Avatar
    dontbeaprix is offline CarAudio.com Elite



    Join Date
    May 2011
    Location
    Indiana
    Posts
    920
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: How long have you been using your amplifier make\model\time

    have had my mb quart discuss 2150 in 2 cars and 5 years. Have had it wired to 1 ohm wich it's not rated for and ran diff subs and now componets.



    2001 Pontiac Grand Prix
    *stock audio for now*

Closed Thread
Page 14 of 18 FirstFirst 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 LastLast

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum