Closed Thread
Results 1 to 3 of 3

Reload Thread: Help Punch 150 Amp making noise Not speakers

  1. #1
    gamebucketman's Avatar
    gamebucketman is offline Junior Member



    Join Date
    Sep 2007
    Location
    Saint George, UT
    Posts
    29
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Help Punch 150 Amp making noise Not speakers

    I just got a brand new Rockford Fosgate punch 150 25 to life. I disconected my old amp and hooked the punch 150 up. When I turn on the ignition I hear what I describe as a electronic squeal like sound. The sound is NOT coming from the speakers it is coming from the amplifier itself.

    If I move the amp around the sound will change much like when a microphone is too close to a speaker and you get feedback. Sometimes the sound goes away completely depending on how the amp is angled it seems. Let me know what you guys think. Thanks







  2. #2
    iDesignBoxes's Avatar
    iDesignBoxes is offline This many.



    Join Date
    Mar 2008
    Location
    USA
    Posts
    453
    Post Thanks / Like
    Mentioned
    0 Post(s)

  3. #3
    gamebucketman's Avatar
    gamebucketman is offline Junior Member

    Threadstarter


    Join Date
    Sep 2007
    Location
    Saint George, UT
    Posts
    29
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Help Punch 150 Amp making noise Not speakers

    well I put the endcap on and the noise stopped. Is it a safety feature maybe because the endcap is a pretty big piece of heatsink? either way it is working perfect now.




Closed Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum