Closed Thread
Results 1 to 7 of 7

Reload Thread: Amp powering off when grounded?

  1. #1
    airmax's Avatar
    airmax is offline Junior Member



    Join Date
    Aug 2007
    Location
    glasgow
    Posts
    4
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Amp powering off when grounded?

    Hi there, i have a bit of a problem, i dont know much either so im looking for some help. I have an amp and sub in my car, it has worked fine for the last few weeks, but some how it has stopped working, i played around with it and worked out that the power LED on the amp switches off when the amp is grounded. When the amp is not grounded the power LED is on and red. The red color means its protected(i.e its not grounded) it should be a green led when the amp is working fine. So why does it do this, is it a fuse problem?
    Anyone with experience have any ideas?
    Thanks







  2. #2
    amedeuce's Avatar
    amedeuce is offline :crap:



    Join Date
    Jan 2004
    Location
    CA
    Posts
    1,759
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amp powering off when grounded?

    the amp needs to stay grounded.
    What amp is it?
    What were you doing when it stopped working?
    Did you check the fuses on the amp?
    Did you check the fuse under the hood?




  3. #3
    kross's Avatar
    kross is offline CarAudio.com Elite



    Join Date
    Jul 2007
    Location
    Seattle, WA
    Posts
    764
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amp powering off when grounded?

    Check the wiring to the sub, make sure there isn't a short somewhere. Also, does it still go into protect if the speaker wire to the sub is completely disconnected from the amp?




  4. #4
    airmax's Avatar
    airmax is offline Junior Member

    Threadstarter


    Join Date
    Aug 2007
    Location
    glasgow
    Posts
    4
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amp powering off when grounded?

    Ok il check this tommorow guys, its a twister amp. But if the fuses are gone or there is a short, surley they red LED wouldnt even light, or am i wrong?
    Just think its wierd how its getting power but all of a sudden when its grounded theres nothing!




  5. #5
    airmax's Avatar
    airmax is offline Junior Member

    Threadstarter


    Join Date
    Aug 2007
    Location
    glasgow
    Posts
    4
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amp powering off when grounded?

    Ok well, ive tried a few suggestions to no avail. There are no shorts at all. The red LED comes on for a few seconds when the car starts, then goes completly off. When the amp is not grounded, the red LED stays on.

    How do i get the fuse out to test it? It seems to be stuck in a plastic case into the amplifier, i took the 2 small screws out around it but it seems stuck fast, i cant get it out to test if its blown or not. Also i dont know how to test if the fuse in the power cable is blown, can anyone help?

    If the fuse/s are blown, would the red LED still come on?

    Also it does still go into protect when the speaker wire to the amp is completley disconnected

    Im trying to eliminate the possibilities here.
    thanks




  6. #6
    luvinthebass's Avatar
    luvinthebass is offline CarAudio.com Elite



    Join Date
    Dec 2004
    Location
    Middle of Iowa
    Age
    29
    Posts
    10,436
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amp powering off when grounded?

    Quote Originally Posted by airmax View Post
    Ok well, ive tried a few suggestions to no avail. There are no shorts at all. The red LED comes on for a few seconds when the car starts, then goes completly off. When the amp is not grounded, the red LED stays on.

    How do i get the fuse out to test it? It seems to be stuck in a plastic case into the amplifier, i took the 2 small screws out around it but it seems stuck fast, i cant get it out to test if its blown or not. Also i dont know how to test if the fuse in the power cable is blown, can anyone help?

    If the fuse/s are blown, would the red LED still come on?

    Also it does still go into protect when the speaker wire to the amp is completley disconnected

    Im trying to eliminate the possibilities here.
    thanks
    the reason it stays on is cuz ur power cable is connected to the amp and it's drawin from ur battery, make sure ur ground is good and ur remote turn on wire is connected to ur headunit then maybe just maybe ur amp will get out of protect if ur ground is good, it's happend to me before and it was the ground, it was loose, use pliers if you can't get the fuse out (i use pliers all the time for fuses) or those fuse pullers, if the fuse in the power cable is blown it will look kinda burnt and will be split in half, hope this helps.




  7. #7
    airmax's Avatar
    airmax is offline Junior Member

    Threadstarter


    Join Date
    Aug 2007
    Location
    glasgow
    Posts
    4
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amp powering off when grounded?

    blade fuse was blown, thanks for the help guys




Closed Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum