Closed Thread
Results 1 to 5 of 5

Reload Thread: Orion XTR 900 blowing fuses

  1. #1
    Join Date
    Dec 2005
    Location
    Boulder
    Posts
    110
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Orion XTR 900 blowing fuses

    I got this a few months ago and just now had the time to install it. I am using it to power two RSD12D subs. They are each getting 450RMS. Well it worked fine the first time I turned it on, for about ten minutes. I went and turned the truck on and got nothing. The fuses on the amp blow as soon as the remote kicks the amp on. I took the amp out and hooked up an identical xtr900 to the exact same power, speaker, and RCA connections. No problem. Works fine. So what happened to the other amp? I know it is probably an internal problem but what can I do to diagnose it aside from sending it out? Thanks.







  2. #2
    XTRProBoy's Avatar
    XTRProBoy is offline Senior VIP Member



    Join Date
    Sep 2006
    Location
    Toronto, ON Canada
    Posts
    168
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Orion XTR 900 blowing fuses

    If it's blowing fuses with nothing connected to it other than power, ground and remote, it's more than likely it has an internal problem and will have to be repaired




  3. #3
    boulderbronco's Avatar
    boulderbronco is offline Member

    Threadstarter


    Join Date
    Dec 2005
    Location
    Boulder
    Posts
    110
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Orion XTR 900 blowing fuses

    Quote Originally Posted by XTRProBoy View Post
    If it's blowing fuses with nothing connected to it other than power, ground and remote, it's more than likely it has an internal problem and will have to be repaired
    Thanks but I figured that. Any idea on the exact problem? Something that perhaps is the usual cause? I know these things happen quite often to all kinds of amps. I was hoping maybe I would be able to fix it myself? I am good with a soldering iron.




  4. #4
    boulderbronco's Avatar
    boulderbronco is offline Member

    Threadstarter


    Join Date
    Dec 2005
    Location
    Boulder
    Posts
    110
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Orion XTR 900 blowing fuses

    bump




  5. #5
    dennisthamenace's Avatar
    dennisthamenace is offline CarAudio.com Elite



    Join Date
    Aug 2006
    Location
    shoreline,WA
    Posts
    500
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Orion XTR 900 blowing fuses

    i had the same problem, amp is blown



    Car: Infiniti I30
    Box: 4.0cf @29.5hz
    Subwoofer: 15" tc-3000
    Amplifier: Power Acoustik A3000DB

Closed Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum