Closed Thread
Results 1 to 14 of 14

Reload Thread: amp won't turn on? help...

  1. #1
    pw91686's Avatar
    pw91686 is offline CarAudio.com Elite



    Join Date
    Jan 2005
    Location
    Mobile, AL
    Posts
    966
    Post Thanks / Like
    Mentioned
    0 Post(s)

    amp won't turn on? help...

    I was wiring up my amp. I was unaware that I had a fuse in the fuse holder. I hooked up the rca cables and the remote wire first (i am thinking I shouldn't have hooked up the rca's first but i'm not sure). Then, I hooked up the ground wire, and then hooked up the wire from the battery and it sparked the first time, then I put it in and it didn't spark. So, I thought everything was hooked up fine, but now it won't turn on. Does anyone know what the problem might be?



    Roll Tide!




  2. #2
    Join Date
    Nov 2005
    Location
    Pohang, Korea
    Age
    43
    Posts
    833
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: amp won't turn on? help...

    Quote Originally Posted by pw91686
    I was wiring up my amp. I was unaware that I had a fuse in the fuse holder. I hooked up the rca cables and the remote wire first (i am thinking I shouldn't have hooked up the rca's first but i'm not sure). Then, I hooked up the ground wire, and then hooked up the wire from the battery and it sparked the first time, then I put it in and it didn't spark. So, I thought everything was hooked up fine, but now it won't turn on. Does anyone know what the problem might be?
    Fuse blown?



    2007 Pontiac Solstice GXP

  3. #3
    pw91686's Avatar
    pw91686 is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Jan 2005
    Location
    Mobile, AL
    Posts
    966
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: amp won't turn on? help...

    they din't seem to be blown, but i guess i could go buy a few and put em in and see if that is the problem....



    Roll Tide!

  4. #4
    Join Date
    Nov 2005
    Location
    Pohang, Korea
    Age
    43
    Posts
    833
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: amp won't turn on? help...

    Look for this:


    Or if you have different types, look for the peice of metal in the middle. If its not connected, its blown.

    It could also be that your remote wire is grounded out or not even connected. Check it with a DMM or follow it back to the head unit.

    It doesn't matter what order you hooked every thing up. But you should always save the fuse for last. In other words, it should be the last thing you install...



    2007 Pontiac Solstice GXP

  5. #5
    pw91686's Avatar
    pw91686 is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Jan 2005
    Location
    Mobile, AL
    Posts
    966
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: amp won't turn on? help...

    i dont have the map with me right now, but i took out one of the fuses, and it wasn't blown



    Roll Tide!

  6. #6
    Join Date
    Nov 2005
    Location
    Pohang, Korea
    Age
    43
    Posts
    833
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: amp won't turn on? help...

    Do you have an inline fuse on the cable between the positive (+) post on the battery and the positive (+) terminal on the amp?



    2007 Pontiac Solstice GXP

  7. #7
    mazdakid's Avatar
    mazdakid is offline CarAudio.com Veteran



    Join Date
    Oct 2004
    Location
    illnoise
    Age
    30
    Posts
    10,357
    Post Thanks / Like
    Mentioned
    42 Post(s)

    Re: amp won't turn on? help...

    try a wire from the power wire to the remote terminal and see if it turns on




  8. #8
    skmfkr's Avatar
    skmfkr is offline CarAudio.com Veteran



    Join Date
    Jan 2005
    Location
    Savannah, GA
    Age
    28
    Posts
    6,309
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: amp won't turn on? help...

    i always do the power wire first



    '08 Ford Escape XLT
    2 12" DC XL's + 2 RD D9s
    Selenium and Crescendo on AQ4X90

  9. #9
    Join Date
    Nov 2005
    Location
    Pohang, Korea
    Age
    43
    Posts
    833
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: amp won't turn on? help...

    Quote Originally Posted by skmfkr
    i always do the power wire first
    And melt it! LOL!!!!!





    2007 Pontiac Solstice GXP

  10. #10
    dleccord's Avatar
    dleccord is offline CarAudio.com Veteran



    Join Date
    Oct 2005
    Location
    Sacramento
    Posts
    5,940
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: amp won't turn on? help...

    yeah both my amps didnt turn on last week, it was the remote wire that got loose somehow



    REFS
    blackgeltabs, theCybe(2x), xplcitcustmz, mabel4life, bumpn_gt , PENER, BLD 25, j3bus2k3(3x) , PRIVATEpastry, guy022077(3x), alpine3612, 03tibgt, rocky 59, mattmcss, yotabeater,pepsican, iceteebone(2x), sfsloop @ mac. com, vincemarq, maldecido33, dalucifer, BassAddictJ, thakidgame, Scoobydoo, marcusb419er, nVRuckus, frkkevin, killahbean, CBFryman2, Zeuslicious(2x), bizzy07, expo5.0, dragonrage, 1loudsuv, nismos14, James Bang, mtlhead, Rsx_03, thaster, teamsubgopoof, CRAZYCORNUTS18, ggk, Colt9699(2x), thangalang, BloodStalker999, dwaynem, chaunb3400, volstitan908, blackbonnie, Fast1one, nineball, rbiele126, JayRich, Al_Capowned, runwitbass

  11. #11
    Join Date
    Nov 2005
    Location
    Pohang, Korea
    Age
    43
    Posts
    833
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: amp won't turn on? help...

    Secure the remote wire to the power wires with zip-ties...



    2007 Pontiac Solstice GXP

  12. #12
    pw91686's Avatar
    pw91686 is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Jan 2005
    Location
    Mobile, AL
    Posts
    966
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: amp won't turn on? help...

    Quote Originally Posted by GO-N DEF
    Do you have an inline fuse on the cable between the positive (+) post on the battery and the positive (+) terminal on the amp?
    that is what i was talking about, the inline fuse holder already had a fuse in it when i was trying to hook it up, that is why it sparked

    what do you mean secure the remote wire to the power wire?



    Roll Tide!

  13. #13
    Join Date
    Nov 2005
    Location
    Pohang, Korea
    Age
    43
    Posts
    833
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: amp won't turn on? help...

    Quote Originally Posted by pw91686
    that is what i was talking about, the inline fuse holder already had a fuse in it when i was trying to hook it up, that is why it sparked

    what do you mean secure the remote wire to the power wire?
    Do this in this order and then reply:

    Examination:

    1. Check to see if you in-line fuse on your positive wire is blown.
    2. Check all of the other fuses in the vehicle.
    3. Check the external fuses on your amp if there are any.
    4. Follow the "remote" wire (little blue one) from the amp to the head unit to see if it is grounded or disconnected.
    5. Follow the Power wire to the battery to see if it is grounded.

    Course of Action:

    1. If any fuses are blown replace them.
    2. If the remote or power wires are exposed (wires sticking through the middle of the sheath) (the ends of the wire are supposed to stick out), replace it or tape it.
    3. If the remote or power wires are disconnected, re-connect them.

    I can't break it down any more simple than that...


    As far as securing the remote wire to the power wire goes, once you have them hooked up to the amp, take a couple of zip-ties and wrap them around the 2 power wires AND the 1 remote wire so that they are all bundled together. Place them about 6 inches apart with the first one about 2 inches from the amp.

    Once again, I can't break it down any more simple than that...



    2007 Pontiac Solstice GXP

  14. #14
    mazdakid's Avatar
    mazdakid is offline CarAudio.com Veteran



    Join Date
    Oct 2004
    Location
    illnoise
    Age
    30
    Posts
    10,357
    Post Thanks / Like
    Mentioned
    42 Post(s)

    Re: amp won't turn on? help...

    ok or you can try what i said, and you will probably find out that the remote wire on the head unit isnt good anymore. ive seen it happen in a bunch of cars




Closed Thread

Similar Threads

  1. How do I turn on the Factory Amp in a Ford ZX2 w/ premium sound???????
    By catthomas in forum Wiring, Electrical and Installation Help
    Replies: 7
    Last Post: 07-20-2010, 03:14 PM
  2. Teh vacuum tube amp versus teh solid state amp
    By Raven in forum Home Audio/Video
    Replies: 19
    Last Post: 09-22-2005, 10:20 PM
  3. Newb Help.. amp wont turn on!!!!!
    By shy6114 in forum Amplifiers
    Replies: 4
    Last Post: 01-19-2004, 11:20 AM
  4. URGENT need help! amp wont turn on?
    By xplicit in forum General Discussion
    Replies: 5
    Last Post: 05-01-2003, 08:08 PM
  5. Amp Remote Turn On & Line level Convertersl
    By Gord95 in forum Wiring, Electrical and Installation Help
    Replies: 9
    Last Post: 02-02-2003, 05:03 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum