Closed Thread
Results 1 to 15 of 15

Reload Thread: taking my system to best buy for install...some question about impedence(ohms)

  1. #1
    scheibler's Avatar
    scheibler is offline Senior VIP Member



    Join Date
    Dec 2005
    Location
    St. Louis, MO
    Posts
    399
    Post Thanks / Like
    Mentioned
    0 Post(s)

    taking my system to best buy for install...some question about impedence(ohms)

    Tommrow I am taking my system up to bestbuy for a full install. I know alot of you will probly tell me to stay away from bestbuy, but I don't really trust my friends who say they know what they are doing. Here is all of my equipment:

    Orion 600d http://www.orioncaraudio.com/amps/Dmono.asp
    Kicker 10" Solo-baric L5 dual 2ohm http://www.cardomain.com/item/KIC05VS10L52
    Kenwood KDC-MP628 http://www.sonicelectronix.com/item_3550.html

    How will I know that they have ran my sub/amp @ 1ohm since the 600d is 1 ohm stable and I can get the most power from that? What should the a,p be set on, master or slave? Just want to make sure that they get he install right and don't screw me over since I don't really know much about installing a system.







  2. #2
    John3000's Avatar
    John3000 is offline CarAudio.com Elite



    Join Date
    Jan 2004
    Location
    Georgia
    Posts
    1,094
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: taking my system to best buy for install...some question about impedence(ohms)

    Quote Originally Posted by scheibler
    Tommrow I am taking my system up to bestbuy for a full install. I know alot of you will probly tell me to stay away from bestbuy, but I don't really trust my friends who say they know what they are doing. Here is all of my equipment:

    Orion 600d http://www.orioncaraudio.com/amps/Dmono.asp
    Kicker 10" Solo-baric L5 dual 2ohm http://www.cardomain.com/item/KIC05VS10L52
    Kenwood KDC-MP628 http://www.sonicelectronix.com/item_3550.html

    How will I know that they have ran my sub/amp @ 1ohm since the 600d is 1 ohm stable and I can get the most power from that? What should the a,p be set on, master or slave? Just want to make sure that they get he install right and don't screw me over since I don't really know much about installing a system.

    Besided putting that stuff in what else are they doing? Are they building your box, running wire etc....? Did they give you a quote? Also they SHOULD know what ohm load to wire your sub up to, but if you have doubts make sure you tell them just in case they fudge something up.



    Refs: 99StangGt, Fandl, IonSQL, dbman150, pdtran

  3. #3
    Mr. Opportunist's Avatar
    Mr. Opportunist is offline CarAudio.com Veteran



    Join Date
    May 2005
    Location
    Chicago, IL
    Posts
    3,564
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: taking my system to best buy for install...some question about impedence(ohms)

    Dont have them do it...




    Quote Originally Posted by the12voltsux View Post
    You low voltage may be due to having three batteries. have you tried only using one battery?

  4. #4
    Randy Savage's Avatar
    Randy Savage is offline CarAudio.com Veteran



    Join Date
    Oct 2002
    Location
    New York
    Age
    30
    Posts
    21,081
    Post Thanks / Like
    Images
    10
    Mentioned
    4 Post(s)

    Re: taking my system to best buy for install...some question about impedence(ohms)

    Just make sure you tell them that the amp is 1 ohm stable, and the sub is dual 2 ohm and you want it wired to 1 ohm.

    Best Buy and CC are hit or miss- some of them have good installers that know what they are doing, some of them have assclowns that have no clue.





  5. #5
    scheibler's Avatar
    scheibler is offline Senior VIP Member

    Threadstarter


    Join Date
    Dec 2005
    Location
    St. Louis, MO
    Posts
    399
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: taking my system to best buy for install...some question about impedence(ohms)

    I have already run the power and remote wire from my battery to my trunk. So all they will have to do is run the rca's down the other side of my car, hook up my head-unit, and then setup my subs/amp correctly. BTW, that sub/box combo from kicker is what I bought so I won't need a box. THey quoted me $130 with the headunit install kit.....seems really, really high, but I don't really trust my friends installing the headunit. Is their any good online tutorials or vids? I have built a computer and am alright with electronics and soldering and would like to do it myself if I could to save money and gain experience.




  6. #6
    froskillz's Avatar
    froskillz is offline Daddylac



    Join Date
    Jan 2006
    Location
    Vancouver Island, Canada
    Posts
    19
    Post Thanks / Like
    Images
    4
    Mentioned
    0 Post(s)

    Re: taking my system to best buy for install...some question about impedence(ohms)

    To install the head unit all you have to really do is buy the wiring harness and dash kit specific to your car and solder or crimp the same coloured wires together (ie white white white, grey with stripe to grey with stripe) from your wiring harness to your deck. Not something hard to do my any means and it would be a great way to save yourself a few bucks




  7. #7
    bibby's Avatar
    bibby is offline CarAudio.com Elite



    Join Date
    Sep 2004
    Location
    none
    Age
    27
    Posts
    4,938
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: taking my system to best buy for install...some question about impedence(ohms)

    headunit is easy to install, and if all you have to do is the remote, and rca's for your amp, the are easy too, then just hook it all up, its all kind of easy, i hooked up my first system w/o any help.



    If you are viewing my profile from SMD, FSC, or d-series.org, then this is the thread with my refs...
    Refs: http://www.caraudio.com/forum/showthread.php?t=231239

  8. #8
    bibby's Avatar
    bibby is offline CarAudio.com Elite



    Join Date
    Sep 2004
    Location
    none
    Age
    27
    Posts
    4,938
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: taking my system to best buy for install...some question about impedence(ohms)

    Also, get with someone who has the time on these forums to walk through it w/ you when you do it.



    If you are viewing my profile from SMD, FSC, or d-series.org, then this is the thread with my refs...
    Refs: http://www.caraudio.com/forum/showthread.php?t=231239

  9. #9
    scheibler's Avatar
    scheibler is offline Senior VIP Member

    Threadstarter


    Join Date
    Dec 2005
    Location
    St. Louis, MO
    Posts
    399
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: taking my system to best buy for install...some question about impedence(ohms)

    im going to have to do it tommroow. its my only avialable free time between work and school at the moment and I have the full day off. I feel confident I can instal the headunit, but the gain setting on the amp and other settings worry me. I guess I'm gonna start reading the user manuals and give it a whirl.




  10. #10
    flakko's Avatar
    flakko is offline Veteran (my butt)



    Join Date
    Aug 2004
    Location
    So Cal
    Age
    28
    Posts
    10,477
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: taking my system to best buy for install...some question about impedence(ohms)

    Quote Originally Posted by scheibler
    im going to have to do it tommroow. its my only avialable free time between work and school at the moment and I have the full day off. I feel confident I can instal the headunit, but the gain setting on the amp and other settings worry me. I guess I'm gonna start reading the user manuals and give it a whirl.
    hearing the stories from around here, i wouldnt trust ANYONE unless they knew what they were doing with a DMM or O-scope setting the gains on my amp.




    1998 Acura TL 3.2L
    Crappy Sansui DVD player
    Stock Speakers
    ----------------------------------------------------------------------
    "Hi ladies, my name is Wo-Hen Nankan"

    "I like you. You have balls. I like balls."

  11. #11
    scheibler's Avatar
    scheibler is offline Senior VIP Member

    Threadstarter


    Join Date
    Dec 2005
    Location
    St. Louis, MO
    Posts
    399
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: taking my system to best buy for install...some question about impedence(ohms)

    **** that sux b/c I don't any1 who really knows in detail and how to correctly set the gains and let alone have an o-scope and bestbuy doesn't care thats for sure.




  12. #12
    Prowler573's Avatar
    Prowler573 is offline R.I.P. Gossamer!!



    Join Date
    May 2005
    Location
    Northwest Louisiana
    Age
    41
    Posts
    18,522
    Post Thanks / Like
    Images
    3
    Mentioned
    0 Post(s)

    Re: taking my system to best buy for install...some question about impedence(ohms)

    Quote Originally Posted by scheibler
    Orion 600d http://www.orioncaraudio.com/amps/Dmono.asp
    Kicker 10" Solo-baric L5 dual 2ohm http://www.cardomain.com/item/KIC05VS10L52
    Kenwood KDC-MP628 http://www.sonicelectronix.com/item_3550.html

    How will I know that they have ran my sub/amp @ 1ohm since the 600d is 1 ohm stable and I can get the most power from that? What should the a,p be set on, master or slave? Just want to make sure that they get he install right and don't screw me over since I don't really know much about installing a system.
    My opinion of your using Best Buy to get your gear installed notwithstanding let me see if I can address your actual questions:
    To make a Dual 2 Ohm sub have a nominal impendence of 1 Ohm you'll want both coils wired in parallel.
    Make certain that both positive coil inputs are connected to the positive output terminal on the amp and likewise for the negative coil inputs. Whether they run a dedicated wire to each coil input or create a jumper from one positive to the other and one negative to the other doesn't matter - so long as the end result is the same.

    The Master/Slave swith should be set to Master. I don't know the exact method of daisy-chaining those Orion amps but if you're only using the lone amp then you'll want that set to Master ~ I do know that much.

    Good luck with it and here's hoping you get someone that has a clue doing your install



    Refs: [CA.com] [eBay.com]



  13. #13
    scheibler's Avatar
    scheibler is offline Senior VIP Member

    Threadstarter


    Join Date
    Dec 2005
    Location
    St. Louis, MO
    Posts
    399
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: taking my system to best buy for install...some question about impedence(ohms)

    thanks, thats some great info. I'm going to save some money by installing the headunit and running the rcas down the other side of my car tommorow on my own. Then I won't have to take my ride to bestbuy and can go to a specialty car audio store in my area to hook up my amp/sub and have them set the gains correctly. What tools will I need to install my headunit in my 1999 nissan maxima without bose system?




  14. #14
    cazorp's Avatar
    cazorp is offline Senior VIP Member



    Join Date
    Dec 2005
    Location
    Shreveport,LA
    Posts
    406
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: taking my system to best buy for install...some question about impedence(ohms)

    if u want u can pm me tommorow, ill walk u through how to set gains and evrything on your amp, if you did the power wire you've done the hard part.

    Zach



    Just Living ... Try it Some time

  15. #15
    scheibler's Avatar
    scheibler is offline Senior VIP Member

    Threadstarter


    Join Date
    Dec 2005
    Location
    St. Louis, MO
    Posts
    399
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: taking my system to best buy for install...some question about impedence(ohms)

    sounds good...I haven't fully completed the power wire though...just ran it from hood to trunk. I still need to cut it and place fuse near the battery and should finally be good to go. BTW, is it bad to set your gains too low causing damage to your amps or subs just like setting the gains too high? Sorry for all the questions guys




Closed Thread

Similar Threads

  1. Audio System Setup question
    By icemanGFX in forum Subwoofers
    Replies: 0
    Last Post: 05-02-2005, 03:12 PM
  2. Pioneer system question...
    By supramike07 in forum Subwoofers
    Replies: 5
    Last Post: 02-29-2004, 12:12 AM
  3. Question on factory Bose system
    By KavanM in forum General Discussion
    Replies: 0
    Last Post: 03-27-2002, 02:49 AM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum