Closed Thread
Results 1 to 7 of 7

Reload Thread: Fuse blew in my viper 1200.1 help !

  1. #1
    duckfart's Avatar
    duckfart is offline CarAudio.com Elite



    Join Date
    Sep 2005
    Location
    Long Beach, CA
    Posts
    860
    Post Thanks / Like
    Images
    4
    Mentioned
    0 Post(s)

    Fuse blew in my viper 1200.1 help !

    Okay I have a viper 1200.1 from Ikesound. everything worked fine so far till saturday when I was bumping loud and all the suden my fuse( power fuse near the battery) blows off. I know that no metal was touching and its well grounded. My Gain was set kinda high... Just passing halfway.. could this have caused the fuse to blow.. ?







  2. #2
    DiamondFanatic's Avatar
    DiamondFanatic is offline CarAudio.com Elite



    Join Date
    Aug 2005
    Location
    Oregon
    Posts
    1,013
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Fuse blew in my viper 1200.1 help !

    Yeah a high gain could have caused it to blow, just turn it down a lil bit and replace the fuse... and then see what happens. If it does it again maybe make sure that all of your wiring is right.



    Various random equipment...

  3. #3
    myn's Avatar
    myn
    myn is offline Member



    Join Date
    Sep 2002
    Location
    Columbus, OH
    Posts
    72
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Fuse blew in my viper 1200.1 help !

    Send it back to Ikesound. I've gone through 2 refurbed Viper 1200.1s from them, both yielding the same blown fuse problem (At battery and the 3 30amp internal fuses).

    In my case I didn't even have the gain up.

    My PG500.2 was working fine, no short in my system either.

    I am now running a Kicker KX1200.1 refurb. (24 hours into it now). Much better sounding amp, puts out more power and about the same price.




  4. #4
    Vega's Avatar
    Vega is offline Senior VIP Member



    Join Date
    Dec 2004
    Location
    Chicago
    Posts
    325
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Fuse blew in my viper 1200.1 help !

    The same thing happened to my Viper. It kept swtiching from protection to power and it would make a clicking noise and everytime I would turn it on the fuse under my hood would blow. I ended up getting rid of it since my warranty from ike and Directed had ran out. This time around I think I'm getting the JBL GTO1201.1, Hifonics TX1505D, or BX1605D.




  5. #5
    myn's Avatar
    myn
    myn is offline Member



    Join Date
    Sep 2002
    Location
    Columbus, OH
    Posts
    72
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Fuse blew in my viper 1200.1 help !

    Quote Originally Posted by Vega
    The same thing happened to my Viper. It kept swtiching from protection to power and it would make a clicking noise and everytime I would turn it on the fuse under my hood would blow. I ended up getting rid of it since my warranty from ike and Directed had ran out. This time around I think I'm getting the JBL GTO1201.1, Hifonics TX1505D, or BX1605D.
    I owned the BX1500 prior to my 2 vipers and I will say that the Vipers when they did work for the short 20 mins did sound better. It appeared they took less effort to deliver the same power my BX1500 did.

    However my current KX1200.1 sounds better then both and I would highly recommend it. It can be had for $225 refurbed.




  6. #6
    duckfart's Avatar
    duckfart is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Sep 2005
    Location
    Long Beach, CA
    Posts
    860
    Post Thanks / Like
    Images
    4
    Mentioned
    0 Post(s)

    Re: Fuse blew in my viper 1200.1 help !

    Yeah I replaced the fuse and everything seems to be working fine. I'm set the gain correctly. I'm going to play it for a long time kinda loud to see if I should sent it back to ikesound.




  7. #7
    duckfart's Avatar
    duckfart is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Sep 2005
    Location
    Long Beach, CA
    Posts
    860
    Post Thanks / Like
    Images
    4
    Mentioned
    0 Post(s)

    Re: Fuse blew in my viper 1200.1 help !

    Well NOw I have set tune down the gain; and i have not experience any other problems. Great amp for less than $200. I played it from long beach to Riverside ( over an hour drive) all the time and it never gets hot. the only problem i have encounter thus far is blowing fuses like crazy but I guess it was due to an improperly set gain.




Closed Thread

Similar Threads

  1. Viper 2500.1 blew, what should replace it
    By bobo244 in forum Amplifiers
    Replies: 14
    Last Post: 08-10-2005, 07:39 PM
  2. Viper 1200.1
    By milellie111 in forum Amplifiers
    Replies: 6
    Last Post: 03-15-2005, 11:01 AM
  3. viper 1200.1 owners help...
    By g30ffr3y in forum Amplifiers
    Replies: 5
    Last Post: 02-02-2005, 05:18 PM
  4. blew the power wire fuse, except...
    By sumone in forum General Discussion
    Replies: 0
    Last Post: 04-06-2004, 02:34 PM
  5. 70 amp fuse for jbl 1200.1
    By muffmanaj in forum Amplifiers
    Replies: 3
    Last Post: 01-24-2002, 11:14 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum