Closed Thread
Results 1 to 10 of 10

Reload Thread: amp keeps cutting off

  1. #1
    JHawk972's Avatar
    JHawk972 is offline Junior Member



    Join Date
    Aug 2004
    Location
    DALLAS,TX
    Posts
    5
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    amp keeps cutting off

    ok first of the amp that i got is the hifonics centurion amp to a 12" kicker solo baric L5. When i first installed the setup it was fine(it came out of my old integera) and it sounded real good but one day i wanted to really hide my wires so i unhooked everything and i drop the fues and crack the glass thats around it. I went to radio shack to get another fuse because all the other audio stores were saleing a thing of 6. I got a 60 amp fuse cause it was the only one they have but now when i hooked it up with the new fuse it comes on for like 3 seconds then shits off then i have to flip the switch on and off to come on.(i jus have a flip switch because i wanted to be able to turn it off, its jus a speacker wire from then power to a lil switch to the remote slot in my amp)


    PLEASE HELP ME IM ABOUT TO GO OUT OF TOWN IN LIKE 1HR AND A HALF AND I WONT HAVE TIME TO GET ONLINE WHERE IM GOING.



    sorry so long i wanted to be in detail so yall can help me better.







  2. #2
    PhatTonyDeMarco's Avatar
    PhatTonyDeMarco is offline C0CK,its whats for dinner



    Join Date
    May 2005
    Location
    West Palm Beach, FL
    Posts
    7,725
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: amp keeps cutting off

    Get the correct fuse...




  3. #3
    JHawk972's Avatar
    JHawk972 is offline Junior Member

    Threadstarter


    Join Date
    Aug 2004
    Location
    DALLAS,TX
    Posts
    5
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: amp keeps cutting off

    Quote Originally Posted by PhatTonyDeMarco
    Get the correct fuse...
    u know what size i jus called radio shack and the have a 20,30, and a 60 amp fuses which one do i need?




  4. #4
    PhatTonyDeMarco's Avatar
    PhatTonyDeMarco is offline C0CK,its whats for dinner



    Join Date
    May 2005
    Location
    West Palm Beach, FL
    Posts
    7,725
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: amp keeps cutting off

    Quote Originally Posted by JHawk972
    u know what size i jus called radio shack and the have a 20,30, and a 60 amp fuses which one do i need?

    What amp is it? And if there are others that came with the amp, that are still intact, then get the same fuse rating..

    Most amps, and amp kits, come with replacement fuses.




  5. #5
    JHawk972's Avatar
    JHawk972 is offline Junior Member

    Threadstarter


    Join Date
    Aug 2004
    Location
    DALLAS,TX
    Posts
    5
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: amp keeps cutting off

    hifonics centurion x(i cant tell if its the roman numeral for 10 or x).




  6. #6
    PhatTonyDeMarco's Avatar
    PhatTonyDeMarco is offline C0CK,its whats for dinner



    Join Date
    May 2005
    Location
    West Palm Beach, FL
    Posts
    7,725
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: amp keeps cutting off

    And there are no other exterior fuses located on the amp, besides the one you replaced?...




  7. #7
    JHawk972's Avatar
    JHawk972 is offline Junior Member

    Threadstarter


    Join Date
    Aug 2004
    Location
    DALLAS,TX
    Posts
    5
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: amp keeps cutting off

    oh ok i see wat ur saying. its a green 30 amp. so i should get the 30amp tubular fuse now right?




  8. #8
    PhatTonyDeMarco's Avatar
    PhatTonyDeMarco is offline C0CK,its whats for dinner



    Join Date
    May 2005
    Location
    West Palm Beach, FL
    Posts
    7,725
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: amp keeps cutting off

    Quote Originally Posted by JHawk972
    oh ok i see wat ur saying. its a green 30 amp. so i should get the 30amp tubular fuse now right?

    Wait wait wait.. The fuse you broke isnt a fuse that is on the amp? It is the AGC fuse near the batter for the power cable?

    If that is the case... Get a ~90 amp and call it a day. However, I dont think this will solve your problem of the amp shutting off. I think there is another problem at vey here...




  9. #9
    JHawk972's Avatar
    JHawk972 is offline Junior Member

    Threadstarter


    Join Date
    Aug 2004
    Location
    DALLAS,TX
    Posts
    5
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: amp keeps cutting off

    naw its not on the amp its by the battery.what do u think the problem is? It work perfectly before and now its crap.




  10. #10
    $$mok3d's Avatar
    $$mok3d is offline Bass Fiend



    Join Date
    Apr 2005
    Location
    Ft. Lauderdale, FL
    Posts
    243
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: amp keeps cutting off

    I had a problem like this in the past. My fuse blew out and left these burn marks inside the fuse holder. I just replaced the fuse and it still kept shuttin off. so then i looked at the fuse holder and saw that it could be the probelm. when i replaced the fuse holder problem was solved.



    1998 Mazda Millenia L
    HU: Kenwood Excelon X-790
    Speakers: Alpine Type X
    Speaker Amp: PPI 2150AM
    Sub: Sound Splinter RL-P 15 D2
    Sub Amp: ED Nine.1
    Box: 2 cu.ft sealed
    Electrical: Optima Red Top + Big 3

Closed Thread

Similar Threads

  1. Teh vacuum tube amp versus teh solid state amp
    By Raven in forum Home Audio/Video
    Replies: 19
    Last Post: 09-22-2005, 10:20 PM
  2. Please tell me whats wrong with the amp cutting out
    By Zelott in forum Wiring, Electrical and Installation Help
    Replies: 3
    Last Post: 04-25-2004, 12:37 PM
  3. My amp keeps cutting off!?!?
    By supraman1379 in forum Amplifiers
    Replies: 1
    Last Post: 04-14-2004, 08:53 PM
  4. my amp keeps cutting out...why?
    By audioman in forum Wiring, Electrical and Installation Help
    Replies: 2
    Last Post: 01-01-2002, 06:45 PM
  5. my amp keeps cutting out...why?
    By audioman in forum Wiring, Electrical and Installation Help
    Replies: 2
    Last Post: 01-01-2002, 05:37 PM

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum