Closed Thread
Results 1 to 3 of 3

Reload Thread: HELP! broken amp? or fuse problems? HELP!

  1. #1
    lesesneje's Avatar
    lesesneje is offline Member



    Join Date
    Oct 2005
    Location
    north carolina
    Age
    28
    Posts
    37
    Post Thanks / Like
    Mentioned
    0 Post(s)

    HELP! broken amp? or fuse problems? HELP!

    i have a sony XM-D400P5 800 watt amplifier. every time i hook it up and turn the car on. the two fuses on the amp blow but the car fuse is fine. The fuses on the amp are 2x30amps and the main battery fuse is a 50amp. does anyone know why this is happening? could it be something wrong with the amplifiers inside parts?







  2. #2
    imaspaceguy90's Avatar
    imaspaceguy90 is offline LOUDS10BLAZER=SCAMMER



    Join Date
    Jan 2005
    Location
    Melbourne,FL
    Age
    24
    Posts
    2,507
    Post Thanks / Like
    Images
    17
    Mentioned
    0 Post(s)

    Re: HELP! broken amp? or fuse problems? HELP!

    SOmetimes that can mean a blown amp, or some of your wires on the amp may be crossed. Make sure none of your speaker cables or rca cables are damaged



    REFS:
    1.Erik019*2.BoominBeast*3.SBLAZER
    4.Jordantyler*5.80INCHES*6.Unbonyr
    7.zachzchw*8.Codyst8n*9.10.11.Raven2201X3
    12.Terryracing86*13.Lastcall*14.Milenko515
    15.Dont_smokerocks*16.LoudS10Blazer
    17.Jimmclrk1*18.Mattbrown0761
    19.20.ProjectPat06X3*21.Mountaineer Man
    22.Fosgate140*23.I want SExxx*24.zeanimal2001
    25.Seiser01*26.Dj-torn*27.JeremyZach*28Netherland24
    29.Mjbailey21*30.Skeptikal*31.Ravens9322
    32.Calico33*33.mattmcss*34 ibanezcollector 35.terryracing86
    36 Jordantyler 37 PWRBASS 38.keifersracing
    39. BATman 40 keifersracing 41PhatTonyDeMarco
    LoudS10Blazer IS A SCAMMER

  3. #3
    lesesneje's Avatar
    lesesneje is offline Member

    Threadstarter


    Join Date
    Oct 2005
    Location
    north carolina
    Age
    28
    Posts
    37
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: HELP! broken amp? or fuse problems? HELP!

    How can i tell if the amp is blown? What should i look for? i looked inside the amp and none of the transitors seem to have become unsaudered. everything on the inside LOOKS to be okay and the wires are brand new. just took them off of my kenwood that was running my hcca and it was pounding prety hard. is there a specific part of the inside of the amp i should check out?




Closed Thread

Similar Threads

  1. Alpine CDA-9813 power fuse rating
    By Cosmic Charlie in forum Head Units
    Replies: 2
    Last Post: 09-12-2005, 06:44 AM
  2. fuse by battery necessary??
    By noob with an RS in forum Wiring, Electrical and Installation Help
    Replies: 16
    Last Post: 03-22-2005, 08:26 AM
  3. Inline fuse...how close to battery?
    By deaf16 in forum General Discussion
    Replies: 10
    Last Post: 03-11-2005, 05:31 PM
  4. Fuse holder near battery
    By tractng in forum Wiring, Electrical and Installation Help
    Replies: 6
    Last Post: 12-04-2004, 03:05 AM
  5. Amp power from battery
    By jheaton57 in forum Wiring, Electrical and Installation Help
    Replies: 2
    Last Post: 09-30-2004, 10:26 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum