Closed Thread
Results 1 to 4 of 4

Reload Thread: Power Issues

  1. #1
    RumbleNTheTrunk's Avatar
    RumbleNTheTrunk is offline CarAudio.com Elite



    Join Date
    Jun 2005
    Location
    Liberty, TX
    Age
    24
    Posts
    1,922
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Power Issues

    I got a Ford F-150 reg. cab pickup, and Im running a Alpine 9830, and im aslo going to be putting in some Diamond Audio Hex s600s 6.5"s & Diamond Audio D6 D6300.4 300w amp...And im already having a bit of power issues lol, today my A/c was acting up a bit, and my head unit was coming on, I had to restart my truck and my head unit came on thank god...I was was wondering what I could do to help this, because im afraid with the speakers and amps that my power issues will get worse...maybe a capacitor...or would it be possible to have two batteries? I personally believe it could be alternator trouble.







  2. #2
    jacko's Avatar
    jacko is offline CarAudio.com Elite



    Join Date
    Mar 2005
    Location
    rogers, MN
    Age
    25
    Posts
    584
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Power Issues

    a second battery/cap will only place more strain on your alt because it will have to supply energy to yet another thing on top of the regular batt/operating needs. I'd suspect alternator trouble expesscially since an alt in a truck that size should be able to keep up with such simple demands.




  3. #3
    TrlcKed_OuT's Avatar
    TrlcKed_OuT is offline CarAudio.com Elite



    Join Date
    Feb 2005
    Location
    las Vegas
    Posts
    1,033
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Power Issues

    what year i got a 2001 f150 and i have setup in sig and i barly even geta volt drop...goes from like 14.2 to 13.8



    Current system:
    03 Ford Explorer
    iraggi 300amp alt (on its way)
    Red top under hood and deka 9a31 in back ( on its way)
    stock mids and highs
    Pioneer Z110bt headunit
    1 18'' TC9/Audioque In 6cubes tuned to 32hz
    Audioque 3500D
    Handles the lows just fine

  4. #4
    kuijo's Avatar
    kuijo is offline CarAudio.com Veteran



    Join Date
    Mar 2005
    Location
    TX
    Age
    27
    Posts
    2,681
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Power Issues

    Ya, i've got 2 amps, and have no problems in my f150.




Closed Thread

Similar Threads

  1. sub selection
    By DeKaL44 in forum Subwoofers
    Replies: 15
    Last Post: 12-08-2005, 03:35 AM
  2. Audiobahn vs. Power Acoustik
    By 94ranger in forum Subwoofers
    Replies: 7
    Last Post: 05-29-2005, 12:55 PM
  3. power 12.5 or 14.4
    By cooldrmoney in forum Wiring, Electrical and Installation Help
    Replies: 1
    Last Post: 11-15-2002, 10:37 PM
  4. Replies: 2
    Last Post: 03-28-2002, 07:38 AM
  5. Power handling of component sets
    By Unregistered in forum General Discussion
    Replies: 1
    Last Post: 02-02-2002, 05:42 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum