Closed Thread
Results 1 to 3 of 3

Reload Thread: Soundstream Rub1.400

  1. #1
    Join Date
    Apr 2013
    Location
    Seattle Area
    Age
    49
    Posts
    38
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Soundstream Rub1.400

    So I've had a couple weeks to play around with my new Rubicon 1.400. I was originally leaning towards a class D because after reading up, they tend to run cooler and are more compact.

    When I found the Rubicon online for $99 shipped I took the bait even though it's an A/B. I was a bit concerned after reading reviews about this model getting hot. I decided for that price I'd give it a go and hope for the best.

    I fabbed up a wood shelf and under mounted it to the rear deck with steel brackets I made to keep it out of the way. Once again i worried about heat being trapped under there but decided to see how it does. I decided I could always install a fan if there was a problem

    I'm driving an Infinity 1262W wired for 2 ohms and 300 watts RMS. Figured 400 watts RMS from the amp would give me a little headroom.

    After playing around with it for a couple of weeks, I found a spot in the gain just where the hum dies off. Right now it sounds about perfect. I've run it for 2-3 hours straight and pushed it hard once the sub was broken in. The amp never gets real hot.

    It's very clean and has plenty of output for my purposes. The gain knob could have better indexing and that's my only complaint. Killer amp for the money.







  2. #2
    Driv3's Avatar
    Driv3 is offline Member



    Join Date
    Mar 2013
    Location
    PA represent
    Posts
    58
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Soundstream Rub1.400

    How noisy was this amp without the fan? i just bought a rub 1.1000




  3. #3
    inspector3711's Avatar
    inspector3711 is offline Member

    Threadstarter


    Join Date
    Apr 2013
    Location
    Seattle Area
    Age
    49
    Posts
    38
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Soundstream Rub1.400

    The amp was dead silent.... Until I reached a certain level of gain. I found to get the output I wanted i had to dial in the gain until there was a barely noticeable low hum. The hum is not audible unless there is no music. Oddly enough, when I flip on the headlights the hum goes away completely. Haven't had time to research that just yet (working too much).

    The amp itself makes no noise. It's only the hum coming from the subwoofer between songs that I can barely hear.




Closed Thread

Similar Threads

  1. soundstream Rub1.2500D
    By Fosgate1 in forum Amplifiers
    Replies: 0
    Last Post: 01-30-2010, 10:38 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may edit your posts

1e2 Forum