Closed Thread
Results 1 to 2 of 2

Reload Thread: 4-channel Amp and sub encloser problem

  1. #1
    CorporalFogarty's Avatar
    CorporalFogarty is offline Junior Member



    Join Date
    Jan 2013
    Location
    Portland, MI
    Age
    18
    Posts
    3
    Post Thanks / Like
    Feedback Score
    0
    Mentioned
    0 Post(s)

    4-channel Amp and sub encloser problem

    First of all, sorry if there is a similar post I could have read instead of posting this, but I couldn't find one.
    Ok so I recently bought a new soundstorm 4 channel amp and wired it to my rear speakers and sub encloser. At first it wasn't working at all and I realized that the turn on lead was not connected correctly. After I fixed that I turned the car back on and the amp came on. I slowly adjusted the gain and the rear speakers were working beautiful, but the subs were not running. I reconnected the speaker wiring to the subs (which is bridged) over and over again and still, nothing. I have no idea what it could be. The subs were working perfectly when they were connected with a lower power mono amp, so I doubt that they are the problem. Any advice would be greatly appreciated. Thanks







  2. #2
    matt_bennett05's Avatar
    matt_bennett05 is offline mattchoo!



    Join Date
    Aug 2009
    Location
    South Westerly Georja
    Posts
    3,434
    Post Thanks / Like
    Feedback Score
    11 (100%)
    Mentioned
    16 Post(s)

    Re: 4-channel Amp and sub encloser problem

    What subs are they (specific model, and coils)? How are the subs wired? Need a lot of details on exact equipment here.

    Also, not being any way, but that amp is janky man. Not going to get much out of it powering subs unless they're rated tiny RMS.



    D.D.Q.F.

    Traded with : norrizzle9, BassAddictJ (x2), TWiZTid859, btr, btdickey, mylows10, Sour_Deez, El_Weenie;
    Bought from : NeilBarber, kurtbeast, bubbagumper, cd6551,
    mistergrubbs, gbo559, ltr450racer690, nismos14, ptcmarty,

Closed Thread

Similar Threads

  1. 4 channel amp and 2 subs
    By stenz in forum Wiring, Electrical and Installation Help
    Replies: 5
    Last Post: 02-17-2010, 09:57 AM
  2. wtb a 4 channel amp and a mono amp and a sub
    By hrtbrk1 in forum Wanting to Buy (WTB) - Car Audio
    Replies: 11
    Last Post: 05-28-2008, 10:27 PM
  3. WTT: 5 channel amp and subs for similar
    By the_franchise in forum Wanting to Buy (WTB) - Car Audio
    Replies: 6
    Last Post: 10-27-2007, 09:02 AM
  4. Replies: 7
    Last Post: 08-01-2005, 01:22 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may edit your posts
1e2 Forum