Closed Thread
Page 1 of 3 1 2 3 LastLast
Results 1 to 15 of 40

Reload Thread: Tru Technology B-475 - Not Working?

  1. #1
    C4RE BE4R's Avatar
    C4RE BE4R is offline Junior Member



    Join Date
    Feb 2011
    Location
    Saint Paul
    Posts
    13
    Post Thanks / Like
    Feedback Score
    0
    Mentioned
    0 Post(s)

    Tru Technology B-475 - Not Working?

    Item(s) for Sale:

    Tru Technology B-475



    Item(s) Description/Condition:

    Not working, not sure whats wrong.


    Price:

    $200? Or trade me a whole gang of sound deadener


    Shipping and Miscellaneous Item Information:

    Buyer pays shipping.


    Item Pictures:

    I have pictures, but cannot seem to link to urls?

    i1208.photobucket.com/albums/cc361/c4rebe4r1977/Tag.jpg
    i1208.photobucket.com/albums/cc361/c4rebe4r1977/Front1.jpg
    i1208.photobucket.com/albums/cc361/c4rebe4r1977/Front2.jpg
    i1208.photobucket.com/albums/cc361/c4rebe4r1977/Side1.jpg
    i1208.photobucket.com/albums/cc361/c4rebe4r1977/Side2.jpg
    i1208.photobucket.com/albums/cc361/c4rebe4r1977/Back.jpg

    (List pictures in this section, 1st picture should be your username/date if you have less than 10 positive feedbacks with the i-Trader system or less than 10 references that you have sold to in the past. (These must be listed in your signature, or a link provided to a feedback thread listing these references)).







  2. #2
    hrtbrk1's Avatar
    hrtbrk1 is offline 1ManWreckinCrew



    Join Date
    May 2008
    Location
    Boomer Sooner, OK
    Posts
    5,768
    Post Thanks / Like
    Images
    1
    Feedback Score
    14 (100%)
    Mentioned
    0 Post(s)

    Re: Tru Technology B-475 - Not Working?

    hold on



    If you ever dealt with me in the past...please post how our transation went here...-->http://www.caraudio.com/forum/showthread.php?p=5274098<--...i greatly appreciate your support

  3. #3
    hrtbrk1's Avatar
    hrtbrk1 is offline 1ManWreckinCrew



    Join Date
    May 2008
    Location
    Boomer Sooner, OK
    Posts
    5,768
    Post Thanks / Like
    Images
    1
    Feedback Score
    14 (100%)
    Mentioned
    0 Post(s)

    Re: Tru Technology B-475 - Not Working?









    If you ever dealt with me in the past...please post how our transation went here...-->http://www.caraudio.com/forum/showthread.php?p=5274098<--...i greatly appreciate your support

  4. Thanks C4RE BE4R thanked for this post
  5. #4
    Suicide Bobb's Avatar
    Suicide Bobb is offline SPLC Fails



    Join Date
    Nov 2009
    Location
    Camas, Washington
    Age
    22
    Posts
    6,348
    Post Thanks / Like
    Feedback Score
    13 (100%)
    Mentioned
    35 Post(s)

    Re: Tru Technology B-475 - Not Working?

    Oh lawd.

    Trade me??????? I don't have sound deadener, but I have a few other home and car audio toys



    Quote Originally Posted by benbenondatrack View Post
    when i see small subs i just think of a girl, 12s = teenagers, 15s = man, 18 = King Kong Mandingo Warrior

  6. #5
    C4RE BE4R's Avatar
    C4RE BE4R is offline Junior Member

    Threadstarter


    Join Date
    Feb 2011
    Location
    Saint Paul
    Posts
    13
    Post Thanks / Like
    Feedback Score
    0
    Mentioned
    0 Post(s)

    Re: Tru Technology B-475 - Not Working?

    My trunk and doors need deadening. No other products needed.




  7. #6
    CerwinVega_Fan's Avatar
    CerwinVega_Fan is online now Coolest Member



    Join Date
    Apr 2009
    Location
    Dallas,TX
    Posts
    4,041
    Post Thanks / Like
    Feedback Score
    36 (100%)
    Mentioned
    12 Post(s)

    Re: Tru Technology B-475 - Not Working?

    How much deadner to u need???




  8. #7
    C4RE BE4R's Avatar
    C4RE BE4R is offline Junior Member

    Threadstarter


    Join Date
    Feb 2011
    Location
    Saint Paul
    Posts
    13
    Post Thanks / Like
    Feedback Score
    0
    Mentioned
    0 Post(s)

    Re: Tru Technology B-475 - Not Working?

    Enough CLD and MLV do do my doors? Trunk would be nice too




  9. #8
    C4RE BE4R's Avatar
    C4RE BE4R is offline Junior Member

    Threadstarter


    Join Date
    Feb 2011
    Location
    Saint Paul
    Posts
    13
    Post Thanks / Like
    Feedback Score
    0
    Mentioned
    0 Post(s)

    Re: Tru Technology B-475 - Not Working?

    The amp seems to be stuck in protect mode. When powered on, the blue top leds flash and then dim out, while the red protect led stays lit. When power is removed, the blue leds flash again.

    Here is a video of powering the amp on and off. ( I do it twice in the video)

    s1208.photobucket.com/albums/cc361/c4rebe4r1977/?action=view&current=VIDEO0003.mp4




  10. #9
    Shinju's Avatar
    Shinju is offline CarAudio.com Veteran



    Join Date
    Aug 2008
    Location
    Seattle
    Posts
    4,821
    Post Thanks / Like
    Feedback Score
    5 (100%)
    Mentioned
    23 Post(s)

    Re: Tru Technology B-475 - Not Working?

    I got a Dynamat Xtreme full door kit for 2 doors (new in box) and some Second Skin deadiner tiles. I'll have to see how many of the tiles I got left, I used them on my panels and they work awesome and easy to use no heat gun required.



    List of Ref's Just ask, Shinju on all Car Audio Forums!


    Flawless Ebay Feedback User: Shadox2k2

  11. #10
    C4RE BE4R's Avatar
    C4RE BE4R is offline Junior Member

    Threadstarter


    Join Date
    Feb 2011
    Location
    Saint Paul
    Posts
    13
    Post Thanks / Like
    Feedback Score
    0
    Mentioned
    0 Post(s)

    Re: Tru Technology B-475 - Not Working?

    Quote Originally Posted by Shinju View Post
    I got a Dynamat Xtreme full door kit for 2 doors (new in box) and some Second Skin deadiner tiles. I'll have to see how many of the tiles I got left, I used them on my panels and they work awesome and easy to use no heat gun required.
    Throw in some MLV and Im sure we can work out a deal.




  12. #11
    Shinju's Avatar
    Shinju is offline CarAudio.com Veteran



    Join Date
    Aug 2008
    Location
    Seattle
    Posts
    4,821
    Post Thanks / Like
    Feedback Score
    5 (100%)
    Mentioned
    23 Post(s)

    Re: Tru Technology B-475 - Not Working?

    MLV? Sorry not familar with it explain please



    List of Ref's Just ask, Shinju on all Car Audio Forums!


    Flawless Ebay Feedback User: Shadox2k2

  13. #12
    C4RE BE4R's Avatar
    C4RE BE4R is offline Junior Member

    Threadstarter


    Join Date
    Feb 2011
    Location
    Saint Paul
    Posts
    13
    Post Thanks / Like
    Feedback Score
    0
    Mentioned
    0 Post(s)

    Re: Tru Technology B-475 - Not Working?

    Mass Loaded Vinyl:

    sounddeadenershowdown.com/products/mlv




  14. #13
    Shinju's Avatar
    Shinju is offline CarAudio.com Veteran



    Join Date
    Aug 2008
    Location
    Seattle
    Posts
    4,821
    Post Thanks / Like
    Feedback Score
    5 (100%)
    Mentioned
    23 Post(s)

    Re: Tru Technology B-475 - Not Working?

    How much of this MLV are you wanting?



    List of Ref's Just ask, Shinju on all Car Audio Forums!


    Flawless Ebay Feedback User: Shadox2k2

  15. #14
    C4RE BE4R's Avatar
    C4RE BE4R is offline Junior Member

    Threadstarter


    Join Date
    Feb 2011
    Location
    Saint Paul
    Posts
    13
    Post Thanks / Like
    Feedback Score
    0
    Mentioned
    0 Post(s)

    Re: Tru Technology B-475 - Not Working?

    Lets talk via PM




  16. #15
    gentlejax's Avatar
    gentlejax is offline CarAudio.com Veteran



    Join Date
    May 2003
    Location
    Bossier City, La.
    Posts
    3,412
    Post Thanks / Like
    Feedback Score
    11 (100%)
    Mentioned
    1 Post(s)

    Re: Tru Technology B-475 - Not Working?

    dang. I really should buy this . I can get it fixed. let me think about it.



    Phoenix Gold Outlaw

Closed Thread
Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may edit your posts
1e2 Forum