Closed Thread
Results 1 to 6 of 6

Reload Thread: SPL system help

  1. #1
    Davecubs14's Avatar
    Davecubs14 is offline The Fireman



    Join Date
    Sep 2008
    Location
    Madison, AL
    Age
    23
    Posts
    1,066
    Post Thanks / Like
    Mentioned
    19 Post(s)

    SPL system help

    Ok. I need help from all you spl guys, esp. meca people! I know my set up can do a lot more but not sure what I need to upgrade/do. I'm open to anything. New box/wires/amp/cd player. I took a bunch of pictures of my set up so you guys can see it. Highest i've hit with this set up, 143.8 on the windshield @47 hz. I do not have a meter yet either...
    I've never seen voltage drop, MAYBE .5 for a second.
    My 2 runs of wire between the batteries have been cut up and put together with 1/0 couplers.

    This is for loud daily driver.
    For equipment;
    15 atmos exo
    Audioque 2200d. I'm looking to get the 3500d soon.
    MB quart 4125
    Image dynamics tweeters, dayton 4" mids and phoenix gold 6.5 mids. Even though they don't count in spl, but oh well!
    330 Singer alt
    Xs power 3100, 5100
    2 runs of 1/0. One positive, one negative.
    Big 3 in 1/0 in knu's cca wire. I might upgrade this one first to ofc wire.
    I think that's about it...

    My box build is on here but it's 35x20x18 Slot port; 4.5W 16.5H 18.5L

    Pics!







    Team Audio Technix

    2011 and 2012 Meca Street 2 AL State Champ

    AL Meca Street 2 Record Holder

    2012 Meca Street 2 World Finals - 3rd Place




  2. #2
    Davecubs14's Avatar
    Davecubs14 is offline The Fireman

    Threadstarter


    Join Date
    Sep 2008
    Location
    Madison, AL
    Age
    23
    Posts
    1,066
    Post Thanks / Like
    Mentioned
    19 Post(s)

    Re: SPL system help

    Holy big pics! Sorry!







    Team Audio Technix

    2011 and 2012 Meca Street 2 AL State Champ

    AL Meca Street 2 Record Holder

    2012 Meca Street 2 World Finals - 3rd Place

  3. #3
    Davecubs14's Avatar
    Davecubs14 is offline The Fireman

    Threadstarter


    Join Date
    Sep 2008
    Location
    Madison, AL
    Age
    23
    Posts
    1,066
    Post Thanks / Like
    Mentioned
    19 Post(s)

    Re: SPL system help











    ---------- Post added at 03:31 PM ---------- Previous post was at 03:30 PM ----------








    Team Audio Technix

    2011 and 2012 Meca Street 2 AL State Champ

    AL Meca Street 2 Record Holder

    2012 Meca Street 2 World Finals - 3rd Place

  4. #4
    sacsking916's Avatar
    sacsking916 is offline stayin high an loud



    Join Date
    Apr 2009
    Location
    emerald triangle..home of da trees
    Posts
    6,428
    Post Thanks / Like
    Mentioned
    6 Post(s)

    Re: SPL system help

    where is your port? cause i cant see it at all in any of the pics. also i would ground your rear battery to the front battery and ground the amp straight to the rear battery, if you arent already.




    TEAM AUDIO TECHNIX
    TEAM SSC
    TEAM CADENCE
    Sold to: imtjnotu; ace_800; omegabunny crazykenkid Bought from: El_weenie; fasfocus00; retroaudioinc; f1mclarenagr; jason19; tone415; twizted859; noph33rracing; tony30cl; carlosg_313 Traded with: Micah_Jones; MikeOfTulsa
    Quote Originally Posted by audioholic View Post
    Apparently I was called out, or called a goat fucker, or something. I really have no idea. Im just along for the ride at this point.
    Quote Originally Posted by CRXBMPN View Post
    King James has nothing on King Sac!

  5. #5
    Dirtrider4eva's Avatar
    Dirtrider4eva is offline √\_The CaUsE__



    Join Date
    Mar 2011
    Location
    Milwaukee, WI
    Posts
    4,289
    Post Thanks / Like
    Mentioned
    16 Post(s)

    Re: SPL system help

    your not alotting enough space between the port and hatch/trunk wall...
    maybe leaking out where your wires to the sub are.
    my two cents.



    welcome to
    Where b-stock is the new a-stock
    TEAM WEST

  6. #6
    sacsking916's Avatar
    sacsking916 is offline stayin high an loud



    Join Date
    Apr 2009
    Location
    emerald triangle..home of da trees
    Posts
    6,428
    Post Thanks / Like
    Mentioned
    6 Post(s)

    Re: SPL system help

    Quote Originally Posted by Dirtrider4eva View Post
    your not alotting enough space between the port and hatch/trunk wall...
    maybe leaking out where your wires to the sub are.
    my two cents.
    All he needs is about 6-7" if he has that then he should be ok. I'm thinking the couplers could be hurting his voltage by a couple tenths, also Op did you silicone the inside of the box where the wires ran in the box?




    TEAM AUDIO TECHNIX
    TEAM SSC
    TEAM CADENCE
    Sold to: imtjnotu; ace_800; omegabunny crazykenkid Bought from: El_weenie; fasfocus00; retroaudioinc; f1mclarenagr; jason19; tone415; twizted859; noph33rracing; tony30cl; carlosg_313 Traded with: Micah_Jones; MikeOfTulsa
    Quote Originally Posted by audioholic View Post
    Apparently I was called out, or called a goat fucker, or something. I really have no idea. Im just along for the ride at this point.
    Quote Originally Posted by CRXBMPN View Post
    King James has nothing on King Sac!

Closed Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum